8月 03, 2008

【解題】Back to High School Physics

@
ACM Volume C 10071 - Back to High School Physics


The Problem

A particle has initial velocity and acceleration. If its velocity after certain time is v then what will its displacement be in twice of that time?


The Input

The input will contain two integers in each line. Each line makes one set of input. These two integers denote the value of v (-100 <= v <= 100) and t(0<=t<= 200) ( t means at the time the particle gains that velocity)


The Output

For each line of input print a single integer in one line denoting the displacement in double of that time.


Sample Input

0 0
5 12


Sample Output

0
120


解題思考

  相信各位物理都有學好。

  速度為 v 的粒子,經歷 2t 時間,所經過的距離就是 2vt 囉。


參考解答(C++)

#include <iostream>

using namespace std;

int main(void)
{
    int v, t;
    while (cin >> v >> t)
    {
        cout << v * t * 2 << endl;
    }

#ifndef ONLINE_JUDGE
    system("pause");
#endif
}

0 回覆:

張貼留言